2.4 Konstruktionsdatei: Unterschied zwischen den Versionen

Aus EEP Wiki
Wechseln zu: Navigation, Suche
 
Zeile 49: Zeile 49:
 
* Menü Datei → Öffnen
 
* Menü Datei → Öffnen
 
* Symbol [[Datei:Symbol_Kondatei_Öffnen.JPG]] oben links
 
* Symbol [[Datei:Symbol_Kondatei_Öffnen.JPG]] oben links
 +
<br>
 
[[Datei:Tipper.gif|left]]
 
[[Datei:Tipper.gif|left]]
<br>
 
 
<div style="margin-left: 10em">
 
<div style="margin-left: 10em">
 
Während Kon-Dateien standardmäßig im aktuellen Objekt gespeichert werden, zeigt der Home-Nostruktor beim Öffnen einer Kondatei das zuletzt zum Öffnen verwendete Objektordner an. Das mag im ersten Moment verwirren, hat aber seine Berechtigung, da Kon-Dateien in verschiedenen Objekten wieder verwendet werden können.
 
Während Kon-Dateien standardmäßig im aktuellen Objekt gespeichert werden, zeigt der Home-Nostruktor beim Öffnen einer Kondatei das zuletzt zum Öffnen verwendete Objektordner an. Das mag im ersten Moment verwirren, hat aber seine Berechtigung, da Kon-Dateien in verschiedenen Objekten wieder verwendet werden können.
Zeile 71: Zeile 71:
 
* Shortcut <tt>Bild ▲</tt> bzw. <tt>Bild ▼</tt> (englischsprachige Tastatur: <tt>PgUp</tt> bzw. <tt>PgDown</tt>)
 
* Shortcut <tt>Bild ▲</tt> bzw. <tt>Bild ▼</tt> (englischsprachige Tastatur: <tt>PgUp</tt> bzw. <tt>PgDown</tt>)
 
* Menü Bearbeiten → Maßstab → Vergroessern (bzw. Verkleinern)
 
* Menü Bearbeiten → Maßstab → Vergroessern (bzw. Verkleinern)
<br><br>
 
<font size="5">[[#top|▲]]</font>
 
== Import externer Objekte ==
 
<br>
 
Bei der Konstruktion eines Objekts wird man in der Regel entweder unmittelbar mit Kon-Dateien arbeiten oder das Objekt aus einem 3D-Konstruktionsprogramm (z.B. Blender) importieren.
 
Es ist aber auch möglich, in einem Objekt Kon-Dateien ''und'' x- (oder n3d-) Dateien zu mischen.
 
Ein Anwendungsfall hierfür ist das überwiegende Arbeiten in einem 3D-Konstruktionsprogramm und das Hinzufügen von speziellen Konstrukten wie Flares mittels Kon-Dateien.
 
 
<br><br>
 
<br><br>
 
<font size="5">[[#top|▲]]</font>
 
<font size="5">[[#top|▲]]</font>

Aktuelle Version vom 21. Mai 2019, 15:11 Uhr



Eine Konstruktionsdatei enthält eine Zeichnung (Ansicht) eines Objektes.
In der Regel entspricht eine Kon-Datei einer Schnitt- oder Risszeichnung eines Bauplans, also etwa dem Grundriss, der Seitenansicht oder der Vorderansicht. Dabei muss die Kon-Datei nicht die vollständige Darstellung eines Objekts in der jeweiligen Perspektive enthalten. Vielmehr werden alle Kon-Dateien vom Home-Nostruktor zu einem Objekt zusammengeführt, um daraus das vollständige Objekt zu erstellen.

Grundbegriffe der Konstruktion


Eine Konstruktionsdatei (im Konstrukteursjargon einfach "Kon-Datei genannt) besteht aus

  • Flächen, welche begrenzt werden von
  • Kanten (Linien), die wiederum eine Verbinung zwischen zwei
  • Vertices darstellen.



Eigenschaften der Flächen


Die Flächen auf einer Kon-Datei müssen nicht eben sein. Die Vertices können nicht nur in X- und Y-Richtung platziert werden, sondern auch in Z-Richtung (Höhe) verschoben werden.
Bei der Konstruktion richtet sich die Oberfläche der Zeichnung zunächst senkrecht in Richtung des Betrachters aus. Die endgültige Lage der Fläche wird im Instanzen-Dialog festgelegt.

Um sich vor unliebsamen Überraschungen zu schützen, sollte man bei der Konstruktion von vorne herein darauf achten, dass

Tipper.gif
  1. alle Flächen tatsächlich eben sind.
    Spätestens bei der Verarbeitung auf der Graphikkarte werden alle Flächen in Dreiecke zerlegt. Wenn die Fläche nicht eben war, wird es auffallen, dass die Zerlegung in Dreiecke auf andere Weise erfolgt als vom Konstrukteur vorgesehen.
  2. alle Flächen konvex sind.
    Wenn man die Kanten um eine Fläche abläuft, sollte an den Vertices die Richtung gleich bleiben oder auf das Zentrum der Fläche zugehen, aber nie nach außen gehen.

Flächen, die diese Bedingungen nicht erfüllen, sollten vom Konstrukteur selbst in kleinere Flächen zerlegt werden.

Arbeiten mit der Kon-Datei

Anlegen einer Kon-Datei


Voraussetzung für die Anlage eine Konstruktionsdatei ist ein geöffnetes Projekt.
Es gibt drei Möglichkeiten eine Kon-Datei anzulegen:


In jedem Fall öffnet sich eine leere Zeichenfläche mit einem Koordinatenkreuz, die eigentliche Konstruktionsdatei. Der Name dieser datei setzt sich zusammen aus dem Objektnamen, einem Bindestrich, "Kon_" und fortlaufender Nummerierung (001, 002, 003 usw.)
Sind mehrere Kon-Dateien für ein Objekt notwendig, ist es ratsam, die Datei unter einem neuem, einem "sprechendem" Namen abzuspeichern, z.B. "Seitenwand_Rechts". Dies ist nur möglich im

  • Menü Datei → Speichern unter

Dadurch entsteht eine neue Kon-Datei. Die automatisch generierte Kon-Datei mit dem Namen und der laufenden Nummer bleibt (als leere) Kon-Datei im Objektordner erhalten und kann später bedenkenlos gelöscht werden.

Öffnen einer Kon-Datei


  • Shortcut Strg O
  • Menü Datei → Öffnen
  • Symbol Symbol Kondatei Öffnen.JPG oben links


Tipper.gif

Während Kon-Dateien standardmäßig im aktuellen Objekt gespeichert werden, zeigt der Home-Nostruktor beim Öffnen einer Kondatei das zuletzt zum Öffnen verwendete Objektordner an. Das mag im ersten Moment verwirren, hat aber seine Berechtigung, da Kon-Dateien in verschiedenen Objekten wieder verwendet werden können.



Speichern einer Kon-Datei


Beim Beenden des Home-Nostruktors oder Speichern des Projektes, werden die Kon-Dateien automatisch in dem zu diesem Zeitpukt vorhandenen Zustand mit abgespeichert. Die Kon-Dateien können aber zum Zwecke der Datensicherheit jederzeit zwischengespeichert werden:

  • Shortcut Strg S
  • Menü Datei → Speichern
  • Symbol Symbol Kondatei Speichern.JPG oben links



Ansichtgröße andern (zoomen)


Die neue Zeichenfläche hat einen weißen Hintergrund mit rotem Fadenkreuz. Mit folgenden Methoden kann hinein bzw. heraus gezoomt werden:

  • Scrollrad
  • Symbol Symbol Vergrößern.jpg bzw. Symbol Verkleinern.jpg am unteren Rand
  • Shortcut Bild ▲ bzw. Bild ▼ (englischsprachige Tastatur: PgUp bzw. PgDown)
  • Menü Bearbeiten → Maßstab → Vergroessern (bzw. Verkleinern)



Navigation

↑ Inhaltsverzeichnis

← 2.3 Objekt

2.4 Konstruktionsdatei

2.5 Instanz →