Export aus Blender

Aus EEP Wiki
Wechseln zu: Navigation, Suche

Export aus Blender

Im folgenden Abschnitt wird die Vorbereitung des Exports eines Modells aus dem 3D-Programm Blender in den Home-Nos beschrieben.

Grundlegende Einstellungen im 3D-Programm Blender

Wie in der Abbildung "Grundansicht des 3D-Programmes Blender" zu erkennen ist wird hier in dieser Beschreibung im Blender mit der Spracheeinstellung „deutsch“ gearbeitet.

Diese Einstellung wird unter Datei -> Benutzereinstellung (Tastenkombination Ctrl-Alt-U), in englischer Sprache unter File -> User Preferences, unter dem Punkt System eingestellt und unter „Benutzereinstellungen speichern“ (links unten) abgespeichert. Diese Einstellung wird in der Abbildung 7 dargestellt.

Um einen korrekten Export aus Blender zu gewährleisten wird die Datei „io_export_directx_x.py“ aus der Blender-Version 2.66 benötigt. Diese Datei muss in den Ordner addons eingefügt werden.

! In io-Dateien aus höheren Version fehlen Einstellungen die für den Export in Blender notwendig sind. In der Benutzereinstellung muss nach Neustart des Programmes Blender der Eintrag „Import- Export: DirectX Model Format (.x)“ unter „Add-ons" aktiviert werden. ! Der Eintrag „Import- Export: DirectX X- Format“ (in der folgenden Abbildung rot durchgestrichen) wird empfohlen zu deaktivieren, da sonst beim Exportieren eine Doppelauswahl „DirectX“ entsteht.

Modellaufbau in Blender

Dieser Abschnitt dient nochmals zur Auffrischung der Arbeitsweise in Blender. Dazu wurde ein kleines Haus in Blender erstellt. In der Abbildung 10 sehen wir die Modellteile Dach, Fenster_bel_du, Fenster_bel_hell, Fenster_unbel und Haus in der Szenenansicht. Diese Aufteilung ist notwendig, da in diesem Projekt mit 2 Texturen gearbeitet wird. ! Wichtig ist bei arbeiten mit mehreren Texturen, dass diese alle die gleiche Größe besitzen z.B. 512x512, 800x800, 1024x1024 oder auch 1024x512. ! Im Blender werden alle Modellteile in einer Szene angezeigt welche sich im Programm rechts oben befindet.

In diesem Beispiel wurde das Modellteil „Dach“ mit der Textur-ID 18831 versehen und die anderen Modellteile mit der Textur-ID 18832. Die Fenster wurden in 3 Kategorien aufgeteilt: 1. Fenster beleuchtet dunkel (Fenster_bel_du) 2. Fenster beleuchtet hell (Fenster_bel_hell) 3. Fenster unbeleuchtet (Fenster_unbel)

Dies wird wichtig beim Import in den Home-Nos zur Darstellung der jeweiligen Fenster. In der Abbildung 11 wird nochmal darauf hingewiesen, dass der Glanzpunkt auf 0.0 gestellt werden muss, da dies beim Export mitgenommen wird und das Modell eine ungewollte Glanzeigenschaft im Home-Nos und dann ebenfalls in EEP erhält. In der englischen Sprache wird dies als „Specular“ angezeigt. ! Auch muss jedes Modellteil mit einem Material versehen werden. Sollte dies mal vergessen werden, wird im Home-Nos das importierte Bauteil als teilweise durchsichtig angezeigt.

Export der einzelnen Modellteile in ein X- Files

Nun bereiten wir unseren Export der einzelnen Modellteile in ein X-File vor. Dazu wählt man ein Modellteil aus, hier ist es das Dach, und wähle mit der Taste „A“ im Editiermodus das Modellteil an, so dass alle Flächen des Modellteiles gelblich erscheinen.

Danach wechselt man in den Objektmodus. Die gelben Flächen werden ausgeblendet und das ausgewählte Objekt wird mit einer gelblichen Umrandung dargestellt. Auf der 14: Ansicht Exportieren nach DirectX unter Auswahl Datei linken

Nun wird über Datei -> Exportieren -> DirectX (.x) der Export aufgerufen. ! Wurde der Eintrag „Import-Export: DirectX X-Format“ nicht deaktiviert, erscheint unter Exportieren 2x die Auswahl „DirectX (.x)“ und dies kann dazu führen, dass das falsche DirectX ausgewählt wird und der Home-Nos das X-File nicht erkennt.

Seite in „Export DirectX“ sind die Grundeinstellungen zu sehen die beim erstmaligen öffnen des Export generiert werden. Das sind: - Left_Handed - Rotate X 90 Degrees - Export Textures - Exportieren: All Objekts Dies wird geändert in: - Right-Handed - Apply Modifiers - Export Textures - Exportieren: Ausgewählte Objekts ! Der Punkt „Animations“ brauch nicht geändert werden und bleibt mit „Keine“ bestehen. ! Die geänderte Einstellung bleibt bestehen bis das 3D-Programm Blender geschlossen oder es eigenhändig geändert wird.

Beim Export ist darauf zu achten, dass dem jeweiligen Export der dazugehörige Name des Modellteiles zugeordnet wird. Dies wird in der Zeile oberhalb der angezeigten Dateien eingetragen.


Ich bedanke mich ganz herzlich bei Thomas Becker(TB1) und Roman Iwer(RI1) die dieses Tutorial für dieses Wiki zur Verfügung gestellt haben


Zurück zur Startseite