Kurztutorium Stadthaus

Aus EEP Wiki
Wechseln zu: Navigation, Suche

Kurztutorial Stadthaus

In diesem Projekt soll gezeigt werden, wie ein einfaches Stadthaus nur unter Benutzung des Home-Nostruktors erstellt werden kann.

Dazu wird das Projekt in die Bereiche

-Projekt,
-Objekte,
-*.kon-Dateien und deren Instanzen,
- Achsendialog

unterteilt

Letzter Punkt wird der Export des fertigen Modells nach EEP sein.

8.kurztutorial-stadt-h-3d-betrachter a.jpg



1. Die Vorbereitung

Als ersten Schritt legen wir nun die Textureinstellungen der Textur zum Stadthaus - die der 1000.tga - im Texturenordner des HomeNos an. (Falls wir dies nicht schon bei "Erste Schritte - Das erste Projekt anlegen" getan haben) Hierzu rufen wir uns nun die Texturen.txt Datei auf, die wir im Ordner HomeNostruktor13\Resourcen\Parallels finden. Hierzu kopieren wir - falls noch nicht geschehen - die hier nochmals hinterlegte rot markierte Zeile "Textur{id...}" und fügen Sie in die mit dem Editor geöffnete Texturen.txt Datei ein und speichern die Datei ab. Die Texturen.txt-Datei finden wir im Ordner HOME-Nostruktor13\Resourcen\Parallels.

Textur{ id(1000) name(1000) automipmap() billboarding() magfilter(1) minfilter(5) }



Wichtig ist, daß alle Klammern an ihrem vordefinierten Platz sind. Denn nur so kann der HomeNos einwandfrei auf die Informationen zugreifen. Wenn wir die Zeile der Textur id(1000) nun in die bereits vorhandenen Einträge in der Texturen.txt eingereiht haben, so haben wir die Eigenschaften festgelegt, wie sich unser Bild bzw. unsere Textur bei der Verwendung im HomeNos verhalten soll.

Wichtige Anmerkung:
Hinterlegungen von Texturdateien (wie z.B. der 1000.tga), wie deren dazugehörige Einstellungen in der Texturen.txt im Ordner Resourcen\Parallels werden im HomeNos nur aktiv, wenn die Hinterlegungen vor dem Start des HomeNos durchgeführt werden.
Werden die Änderungen vorgenommen, während der HomeNos bereits aktiv ist, ist ein Neustart des Programms erforderlich.

2. Projekt anlegen

Wir öffnen nun den HomeNostruktor und legen nach dem Start des Programms über "Datei" -> "Neues Projekt" ein neues Projekt mit dem Namen "Stadthaus_Tutorial" an. Bei "Objekt Typ" wählen wir die Einstellung "Festland (Objekt am Land) aus.

Die Benennung "Stadthaus_Tutorial" geben wir im Dialog "Neues Projekt, oder Objekt erstellen" bei Projektname ein. Der Projektname wird uns nach Bestätigen über "Generiere es" sogleich in der oberen Programm-Zeile neben HOME-Nostruktor8.0 angezeigt.

3. Objekt einfügen

Im einem nächsten Schritt fügen wir nun über "Objekt" -> "Füge neues Objekt ein" ein neues Objekt in unser Projekt ein. Hier vergeben wir analog zur Projekterstellung erneut einen Namen. Dies tun wir, indem wir einen Namen bei "Objektname" einfügen. Wir vergeben hier nun den Namen "Stadthaus_Objekt" und bestätigen die Erstellung des Objektes mit "Generiere es". Nun wird uns folgendes Bild im HomeNos angezeigt:



9 aa neues-objekt edit.jpg



Wichtig: Wenn wir ein neues Objekt anlegen bzw. im Objekt-Modus arbeiten, wählen wir in der oberen Leiste bei den Schaltflächen Hmfile hash 750f4a99.jpg Objekt aus!

4. Erstellen der Kon-Dateien im Objekt "Stadthaus-Objekt" <br<
Unser Stadthaus-Objekt besteht aus mehreren sogenannten .kon-Dateien. Diese bilden unserer Grundlage für das Modellieren des Stadthaus in 2D. Wir werden nachfolgend nun vier Außenwände und die dazugehörigen Dachausführung des Stadthauses erstellen.

A) Hausfront
Beginnen wir nun mit der Front des Hauses. Wir gehen hierzu in unserem aktiven Objekt auf "Datei" -> "Neu" und erhalten eine neue .kon-Datei. Diese speichern wir sogleich unter "Front-Stadthaus". Dies tun wir über "Datei" -> "Speichern unter..." und geben dort den Namen "Front-Stadthaus" ein. Im nächsten Schritt modellieren wir nun die Geometrie der Front des Stadthauses. Wir rufen uns über den Button Img 15.jpg das Zeichenwerkzeug für ein Rechteck auf. Das Zeichenwerkzeug wird uns nun als offenes Rechteck rechts neben Mauszeiger als aktiv angezeigt. Wir ziehen nun mit gedrückter linker Maustaste ein beliebig großes Rechteck in unserer 2D-Oberfläche auf und erhalten nun folgenden Dialog "Einstellungen Rechteck":



9 stadthaus-tutorial rechteck-dialog front 2.jpg



Anm.: Eingaben im HomeNostruktor werden stets mit (.) (Punkt) und nicht mit (,) Komma vorgenommen!

Wir geben nun die Werte wie oben im Dialog angezeigt ein. Wir bestimmen über die Eingabe bei "Pos.X:/ Pos.Y:" die Lage des Rechtecks im 2D-Raum und über die Eingabe bei Länge/ Breite bestimmen wir die Größe des zu zeichnenden Rechtecks. Neben Eingaben zu Lage und Größe nehmen wir ebenfalls gleich Eingaben zur Textur vor. Diese Eingaben nehmen wir in den Feldern "Textur X:/Y:" und den zugehörigen Texturfeldern "Länge:" und "Höhe:" wie oben angezeigt vor. Des Weiteren tragen wir bei "Textur-ID:" die Nummer 1000 für die Texturdatei 1000.tga ein. Wir bestätigen die Erstellung des Rechtecks nachdem wir die Eingaben gemacht haben nun mit "OK". Um nun die Lage unseres erstelltes Rechtecks im 3D-Raum zu überprüfen und es uns nachfolgend im 3D-Betrachter anzeigen zu lassen gehen wir auf das Symbol Img 23.jpg und erhalten nach Bestätigen der Schaltfläche "Gehe zu..." den Instanzen-Dialog des Rechtecks bzw. unserer .kon-Datei angezeigt.



9 stadthaus-tutorial instanzen-dialog gehe zu.jpg



9 stadthaus-tutorial instanzen-dialog.jpg



Wie wir im Eintrag der "X-Drehung:" in "Lage der Instanzebene" erkennen können ist bereits eine Drehung von 270Grad (= -90Grad) voreingestellt, d.h. die Front unseres Stadthauses ist bereits senkrecht aufgestellt. Wir bestätigen nun mit "Ansicht aktualisieren" und erhalten im 3D-Betrachter daraufhin folgende Ansicht:



9 stadthaus-tutorial rechteck-dialog front 2-3d-betrachter.jpg



Wir haben somit bereits die Front des Stadthauses fertiggestellt.

Hausseiten

Für unsere Seiten des Hauses erstellen wir nun über "Datei"-> "Neu" eine weitere .kon-Datei. Analog zur Erstellung des Rechtecks für die Front wählen wir nun wieder die Schaltfläche mit dem Symbol Img 15.jpg aus und erstellen über Aufziehen eines Rechtecks unser Seitenteil des Stadthauses. Im sich öffnenden Dialog "Einstellung Rechteck" geben wir nun nachfolgende Werte ein:



9 stadthaus-tutorial rechteck-dialog seite.jpg



Wir bestätigen nun die Erstellung des Rechtecks wieder mit ok und speichern die .kon-Datei über "Datei" -> "Speichern unter..." und geben dort den Namen "Seite-Stadthaus" ein. Danach rufen wir uns über das Symbol Img 23.jpg und "Gehe zu" die Instanzebene unserer .kon-Datei auf. Hier nehmen wir nun folgende Einstellungen vor:



9 stadthaus-tutorial rechteck-dialog seite instanzebene.jpg



Bei "X-Position:" geben wir den Wert -600 ein und geben der Seitenwand über die Eingabe bei "Z-Drehung:" = "-90Grad" eine Drehung um eben -90Grad, da wir die 1. Seitenwand des Hauses am linken Ende der Front setzen möchten - und da die Seitenwand zu -90Grad zur Front gedreht werden muß geben wir -90Grad bei der Drehung um die Z-Achse ein.

Da wir die Seitenwand natürlich ein zweites mal auf der gegenüberliegenden Seite benötigen gehen wir nun zuerst auf "Übernehmen". In einem nächsten Schritt legen wir nun eine neue Instanz - d.h. eine 2.Instanz unserer Hauswand über "Neue Instanz" an. Nach dem Anlegen sehen wir im Instanzen-Dialog "Aktuelle Instanz = 1" - dies bestätigen wir nun mit "Gehe zu" und wir erhalten den Instanzendialog der zweiten Seitenwand angezeigt. Hier tragen wir nun bei "X-Position = 600" ein und wählen bei "Einstellungen der Instanzen" bei "Face-Culling" Vorderseite aus. Da wir unsere 2.Seitenwand ja an das rechte Ende der Front setzen blenden wir hier über "Face-Culling" eben die Vorderseite der darzustellenden Wand aus.



9 stadthaus-tutorial rechteck-dialog seite instanzebene1.jpg



Wir gehen nun auf "Ansicht aktualisieren und erhalten im 3-D Betrachter daraufhin Folgendes angezeigt:



9 stadthaus-tutorial rechteck-dialog seiten-3d-betrachter.jpg



Bei Drehung des Objekts im 3-D Betrachter ist die rechte Seitenwand, die nach innen hin über "Face-Culling" ausgeblendet ist, nun natürlich bereits auch sichtbar.

C) Rückseite

Widmen wir uns als nächstes der Rückseite unseres Stadthauses. Wir erstellen nun über "Datei" -> "Neu" erneut eine neue .kon-Datei und speichern diese über "Datei" -> "Speichern unter" als "Rückseite Stadthaus" ab. Nun gehen wir erneut über das Symbol Img 15.jpg und ziehen wieder ein Rechteck auf. Dort geben wir im Dialog folgende Werte ein:



Hmfile hash ce493060.jpg



...und bestätigen die Erstellung mit "OK". Um nun die Lage der rückseitigen .kon-Datei im Objekt zu bestimmen wählen wir wieder das Symbol Img 23.jpg für den Instanzen-Dialog aus. Dort geben wir nun folgendes ein:



Hmfile hash 8f972355.jpg



Da wir die Rückseite unseres Stadthauses um die Länge der Seitenwände um 1000cm und somit 10m nach hinten versetzen sollen, geben wir bei "Y-Position:" den Wert 1000 ein. Des Weiteren muß unseres Rückseite ja nach hinten sichtbar sein - deshalb drehen wir im Instanzendialog bei "Z-Drehung:" um 180 Grad. Und erhalten im 3D-Betrachter nach bestätigen von "Ansicht aktualisieren" nun folgendes Bild:



Hmfile hash 4f37ae0c.jpg



Damit haben wir nun die Erstellung der vier Seitenwände unseres Stadthauses abgeschlossen. Als nächstes widmen wir uns nun der Modellierung des Daches.

D) Dach

Für das Dach unseres Stadthauses erstellen wir insgesamt zwei .kon-Dateien, da wir 2 unterschiedlich abgeschrägte Dachhälften und Dachflächen haben, die zum einen zur Front und zum Anderen zu den Seiten ausgerichtet sind.

Dach Teil 1

Beginnen wir nun mit der Erstellung der ersten .kon-Datei zum Dach und legen über "Datei" -> "Neu" wieder eine neue .kon-Datei an, die wir als gleich unter dem Namen "Dach-Stadthaus" abspeichern. Für die Erstellung der beiden Dachhälften benötigen wir entgegen unseren Seiten des Stadthauses trapezförmige Bauteile. Diese können wir nun nicht alleinig über den Dialog "Einstellung Rechteck" erstellen, sondern müssen diese nach der Erstellung über den Dialog händisch anpassen. Wir gehen nun allerdings erst erneut auf die Schaltfläche Img 15.jpg für die Erstellung eines Rechtecks und geben nachfolgende Werte für unser erstes Bauteil des Daches ein:



9 stadthaus-tutorial rechteck-dialog dach haupt.jpg



Wir erhalten nun wieder ein Rechteck dargestellt. Für die händische Anpassung der Einzelpunkte betätigen wir nun die Schaltfläche Img 22.jpg und wählen mit dem dargestellten "Rechteck-Symbol" mit den zwei Pfeilen, den oberen linken Einzelpunkt des Rechtecks an. Dies tun wir, indem wir den oberen linken Einzelpunkt in die Mitte des angezeigten Rechtecks legen und die Auswahl mit der linken Maustaste bestätigen. Im nun sich öffnenden Dialog für den Einzelpunkt/ Vertex geben wir die nachfolgenden Werte ein und bestätigen die Einstellungen nach Eingabe mit "OK".



9 stadthaus-tutorial rechteck-dialog dach haupt einzelpunkt links.jpg



Denselben Vorgang wiederholen wir nun für den rechten, oberen Einzelpunkt und geben dort die folgenden Werte ein und bestätigen nach Eingabe der Werte erneut mit "OK".



9 stadthaus-tutorial rechteck-dialog dach haupt einzelpunkt rechts.jpg



Wenn wir uns nun unsere .kon-Datei "Dach_Stadthaus" ansehen, erhalten wir folgende Darstellung eines Trapez:



9 stadthaus-tutorial rechteck-dialog dach haupt kon.jpg



...somit haben wir den ersten Teil der Dachkonstruktion erstellt - haben aber die Arbeit an diesem Bauteil damit noch nicht ganz abgeschlossen. Zum einen benötigen wir das Bauteil "Dach_Stadthaus" zweimal, d.h wir müssen neben der ersten noch eine zweite Instanz anlegen - für die Vorderseite und Rückseite unseres Hauses. Des Weiteren ist unser Dach in einem gewissen Winkel geneigt. Deshalb rufen wir uns nun über das Symbol Img 23.jpg die Instanzebene unserer .kon-Datei "Dach_Stadthaus" auf und bestätigen als gleich wieder mit "Gehe zu" den Aufruf unserer ersten Instanz. Dort nehmen wir nun die folgenden Einstellungen vor:



9 stadthaus-tutorial rechteck-dialog dach haupt instanzebene1.jpg



Somit haben wir die Lage und den Winkel des vorderen Teil des Daches und damit der ersten Instanz bestimmt. Wir gehen nun auf "Übernehmen" und wählen im nachfolgenden Dialog "Instanzen" nun "Neue Instanz" für die Erstellung einer zweiten Instanz unseres "Dach_Stadthaus" aus. Wir erhalten nun das Dialogfeld "Lage der Instanzebene" für unsere zweite Instanz und somit für die rückwärtige Seite des Daches. Hier geben wir nun die nachfolgenden Werte ein:



9 stadthaus-tutorial rechteck-dialog dach haupt instanzebene2.jpg



kurz zur Erklärung der obigen Eingaben:

Unsere zweite Instanz wird wie wir oben erkennen, um 1000cm und somit 10m um die y-Achse nach hinten verschoben. Diesen Wert geben wir an dieser Stelle ein, da die Seiten unseres Hauses eine Länge von 10m haben und wir nun den zweiten Teil des Dachs an der Rückseite unseres Hauses platzieren möchten. Zusätzlich zu dieser Eingabe nehmen wir bei Z-Drehung eine Eingabe von 180, also von 180Grad vor, da unser rückwärtiger Teil des Dachs natürlich entgegengesetzt zu unserem vorderen Teil des Daches stehen soll.

Wir bestätigen die Eingaben nun mit "Ansicht aktualisieren" und erhalten nachfolgende Darstellung im 3-D Betrachter:



9 stadthaus-tutorial rechteck-dialog dach haupt-fertig 1 -3d-betrachter.jpg



Damit haben wir die Erstellung der ersten beiden Dachhälften abgeschlossen. Wir widmen uns nun der Erstellung der beiden seitlichen Dachhälften.

Dach Teil 2

Legen wir uns nun über "Datei" -> "Neu" wieder eine neue .kon-Datei an, die wir als gleich unter dem Namen "Dach-Stadthaus_Seiten" abspeichern. Wenn wir uns nun die Darstellung des Stadthaus am Anfang des Tutorials oder im obigen Bild ansehen, so erkennen wir daß die Dach-Seiten kein Rechteck, oder die Abwandlung eines Rechtecks (z.B. ein Trapez) bilden, sondern geometrisch als Dreiecke ausgeführt sind. Das heißt wir werden die .kon-Datei bzw. deren geometrische Figur erneut etwas abgewandelt von den Vorherigen erstellen müssen.

Wir gehen nun allerdings erst erneut auf die Schaltfläche Img 15.jpg für die Erstellung eines Rechtecks und geben nachfolgende Werte für unser seitliches Bauteil des Daches ein und bestätigen nach Eingabe der Werte mit "OK":



9 stadthaus-tutorial rechteck-dialog dach haupt 1-seite kon.jpg



...und erhalten folgende Figur:



9 stadthaus-tutorial rechteck-dialog dach seiten.jpg



Wir erhalten durch Ausführen des Rechteck-Dialogs nun erst einmal wieder ein Rechteck als geometrische Figur angezeigt - wissen aber ja bereits, daß wir für die Dach-Seiten ein Dreieck benötigen, um es in die Dachkonstruktion einbringen zu können. Um nun die Rechteck-Figur in ein Dreieck umzuwandeln rufen wir uns als zunächst mit dem Symbol Img 17.jpg das Werkzeug zum löschen von Vertexen auf. Mit dem nun angezeigten Kreuz rechts neben dem Doppelpfeilsymbol gehen wir nun auf den linken oberen Punkt/ Vertex des Rechtecks und löschen diesen mit einem Klick auf die linke Maustaste heraus. Wir erhalten danach folgende Darstellung - sozusagen nur noch einen Rumpfteil eines Rechtecks:



Hmfile hash f590e2f8.jpg



Im einem nächsten Schritt wählen wir nun über die Schaltfläche Img 22.jpg das Werkzeug für die Vertexeigenschaften aus und rufen, nachdem wir das angezeigte Quadrat über den rechten oberen Vertex/ Einzelpunkt gesetzt haben, mit einem Klick auf die linke Maustaste die Eigenschaften des Punktes auf. In den Eigenschaften des rechten oberen Punktes nehmen wir nun folgende Eingaben vor:



9 stadthaus-tutorial rechteck-dialog dach seiten dialog-rechter-vertex 1.jpg



Wir setzen den Punkt zum einen über die Eingabe bei "Horizontale (X):" = 0 in die Mitte x = 0 unseres Koordinatensystems und somit in die Mitte unserer Außenpunkte x unten links = -500 und x unten rechts = 500, zum Anderen nehmen wir mit der Eingabe bei "TexturX:" = 0.74945 die zur Verschiebung des Punktes in x-Richtung zugehörige Anpassung des Texturwertes in X-Richtung vor.
Der Wert "TexturX:" = 0.74945 ergibt sich durch Mittelung der Textur-Werte bei x unten links = 0.5537 und x unten rechts = 0.9452.

Als Rechnung erhalten wir:

Texturwert x bei x 0 = ((Texturwert x unten rechts -[minus] Texturwert x unten links) / [geteilt] 2 ) + Texturwert x unten links

und somit:

Texturwert x bei x 0 = ((0.9452 - 0.5537) / 2)) + 0.5537

= -->> (0.3915 / 2) + 0.5537
= -->> 0.19575 + 0.5537



Texturwert x bei x 0 = 0.74945

Bestätigen wir nun unsere Eingaben für den rechten oberen Vertex erhalten wir folgende Figur:



Hmfile hash 2b142436.jpg



Nun rufen wir uns über das Symbol Img 12.jpg das Werkzeug für das Zeichnen von Verbindungslinien auf und Schließen durch Verbinden des oberen Vertex mit dem unteren linken Vertex die Figur zu einem geschlossenen Dreieck. Die Verbindungslinie setzen wir, indem wir mit dem angezeigten Werkzeug direkt auf den oberen Vertex gehen und nun bei gedrückter linker Maustaste die Linie bis zum unteren linken Vertex aufziehen. Sind wir mit der aufgezogenen Linie nun direkt über dem linken unteren Vertex angelangt, so lassen wir die linke Maustaste los und die beiden Vertexe sind damit verbunden.

Als Ergebnis erhalten für unsere .kon-Datei "Dach-Stadthaus_Seiten" nun folgendes Bild:



9 stadthaus-tutorial rechteck-dialog dach seiten dreieck-fertig.jpg



Den Teil der Modellierung des Bauteils haben wir somit nun abgeschlossen - was nun noch folgt ist das Setzen der Instanzen. Hierfür rufen wir uns nun über das Symbol Img 23.jpg den Instanzendialog auf, bestätigen als gleich "Gehe zu" und gelangen somit zur ersten Instanz unseres Bauteils. In der ersten Instanz nehmen wir nun folgende Eingaben vor:



9 stadthaus-tutorial rechteck-dialog dach seiten instanz1.jpg



Wir setzen durch die Eingabe bei "X-Position" = 600 die erste Instanz des Bauteils an die rechte Außenseite des Stadthaus, setzen das Bauteil über die Eingabe bei "Y-Position" = 500 um 500cm über die y-Achse nach "hinten", so daß das Bauteil mittig auf der Seitenwand sitzt, und heben es über die Eingabe bei "Z-Position" = 1000 auf eine Höhe von 1000cm auf die Oberkante des Seitenwand ( da die Seiten-/ Außenwände eine Höhe von 1000cm = 10m haben).
Abschließend geben wir unserem Bauteil eine Drehung um die x-Achse mit der Eingabe bei "X-Drehung" = 230Grad (somit hat die Seite unseres Dachs eine Dachneigung von 50Grad [180Grad = waagerecht + 50Grad = 230Grad] ) und eine Drehung um die z-Achse mit der Eingabe bei "Z-Drehung" = 90Grad. (hiermit drehen wir unseren Seitenteil des Dachs um 90Grad zum vorderen und rückseitigen Dachteil).

Wir bestätigen nach den Eingaben nun mit "Übernehmen" und legen im Dialogfenster "Instanzen" über "Neue Instanz" ein zweite Instanz für das Bauteil an. Im sich nun öffnenden Instanzendialog "Instanz Nummer1" tragen wir nun die folgende Werte ein:



9 stadthaus-tutorial rechteck-dialog dach seiten instanz2.jpg



Durch den Eintrag bei "X-Position" = -600 setzen wir nun die zweite Instanz des Bauteils an die linke Außenseite des Stadthaus, setzen das Bauteil über die Eingabe bei "Y-Position" = 500 um 500cm genau wie bei der ersten Instanz über die y-Achse nach "hinten", so daß das Bauteil mittig auf der Seitenwand sitzt, und heben es ebenso über die Eingabe bei "Z-Position" = 1000 auf eine Höhe von 1000cm auf die Oberkante des Seitenwand. Über den Eintrag bei "X-Drehung" = 230 geben wir unserem Bauteil ebenso eine Drehung um die x-Achse um 230Grad, so daß die Seite unseres Dachs eine Dachneigung von 50Grad hat.
Bei "Z-Drehung" setzen wir einen Wert von -90Grad und stellen die zweite Instanz unserer Dachseite somit genau entgegengesetzt zu unserer ersten Instanz.

Wir bestätigen die Eingaben nun mit "Ansicht aktualisieren" und erhalten im 3D-Betrachter nun folgendes Bild unseres fertig modellierten Stadthauses:



9 1-stadthaus tutorial abschluss.jpg



E) Setzen im Achsendialog, Externe .ini-Datei und Export des Modells

Um unser Stadthaus nun in unsere EEP-Version integrieren und es dort aufstellen zu können widmen wir uns nun dem Setzen im Achsendialog und anschließend dem Export des Modells in das .3dm-Modell-Format von EEP.

Achsendialog/ Kopplungen

Wir rufen uns nun zunächst über das Symbol 9 ee achsendialog-symbol.jpg den Achsendialog bzw. die Kopplungen des Modells auf. Die Schaltfläche befindet sich in der oberen Leiste und ist im rechten Schaltflächenblock angeordnet. Nachdem wir die Schaltfläche betätigt haben bekommen wir nun das folgende Dialogfenster angezeigt:



9 ee achsendialog.jpg



Wir sehen im oberen Feld die Systemachse "Basis", die sozusagen den Kern unsere Modells bildet. Das Dialogfenster würde uns hier nun die Möglichkeit bieten die Systemachse "Basis" mit weiteren Achsen zu unterkreuzen und diese über diverse Einstellungen wie z.B. "Fußpunkt" im Modell anzuordnen. Da wir aber mit dem Stadthaus kein rollendes oder sonstig bewegliches Modell erstellen, benötigen wir außer der Systemachse "Basis" keine weiteren Achsen.

Wir in der obigen Grafik zu erkennen ist setzen wir nun unser erstelltes Objekt "Stadthaus-Objekt", dass wir über den Reiter "Modell:" auswählen können, auf die Systemachse "Basis" und ordnen der Achse somit das Objekt zu. Wir bestätigen die Auswahl mit "Übernehmen" und erhalten im 3D-Betrachter unser Stadthaus erneut angezeigt. Nur diesmal mit dem Unterschied, dass das Stadthaus nun im Modell gesetzt ist. Dies erkennen wir daran, wenn wir mit den Schaltfächen "Objekt" und "Modell" zwischen der Objektanzeige und Modellanzeige wechseln. Wir werden nun feststellen, dass unser Stadthaus nicht mehr alleinig als Objekt sondern nun bereits auch als Modell sichtbar ist.

Externe .ini-Datei

Um unserem Modell nun noch seinen späteren Namen zu geben, unter welchem es in EEP aufrufbar sein wird, rufen wir uns über das Symbol 9 ee systemini.jpg die Systemeinstellungen auf. Das sich nun erste öffnende Fenster der "Interne Funktionen und Systemeinstellungen des Modells" brauchen wir nicht weiter zu bearbeiten. Einträge wären hier nur zu tätigen, wenn wir das Modell z.B. mit Rauchfunktionen oder Sounds ausstatten wollten. Des Weiteren wären hier für Rollmaterialien Abmessungen, Konfigurationen der Antriebsleistung und weitere Funktionen einzutragen. Da unser Stadthaus allerdings eine Immobilie ohne weitere Funktionen ist gehen wir über die Schaltfläche "Zeige externe Modell-INI" weiter zur "Externe *.ini-Datei des Modells". Wir bekommen nun ein Fenster mit den bereits folgenden Einstellungen angezeigt:



9 ee systemini-dialog externeini.jpg



Bei [FileInfo] erkennen wir bereits den Namen, den unser Stadthaus später in EEP tragen wird und über den es im Programm aufrufbar und einsetzbar sein wird.
Der Eintrag ist bereits automatisch erfolgt und richtet sich nach dem Projektnamen, den wir anfangs vergeben haben. Hier haben wir allerdings nun die Möglichkeit den Namen zu editieren und zu verändern. So könnten wir hier z.B. "Mein_erstes_Stadthaus" eingeben. Die Benennung kann beliebig erfolgen. Ebenfalls können wir hier nun z.B. noch bei Creator_Model und Creator_Original, den Erbauer des Hauses im Original und den Erbauer des Hauses im Modell vermerken. Diese Eintragungen werden später in EEP bei einem Rechtsklick bei der Auswahl des Modells im Aufruf-Fenster angezeigt.
Diese Einstellungen sollen uns an dieser Stelle genügen und wir gehen zum letzten Schritt - dem Export unseres Modells in das Datei-Format von EEP über.

Export des Modells

Bevor wir nun den Export des Modells in das .3dm Format von EEP starten, öffnen wir uns nun abschließend über das Symbol 9 ee projekteinstellungen.jpg die Einstellungen unseres Projekts. Wir erhalten als gleich nun den folgenden Dialog:



9 ee projekteinstellungen 1.jpg



Hier sind für unser Stadthaus nun noch die folgenden Einstellungen zu tätigen:

Über die Copyrightvermerke tragen wir nun unsere Autorenschaft ein und können eine Beschreibung zum Modell hinzufügen. Für den Export selbst sind nun noch 2 wichtige Eintragungen zu machen:

1. Im Feld "Zusätzlicher Kopierpfad..." tragen wir nach "\Resourcen\" nun Modellart bzw. den Resourcenordner ein, in welchen das Modell exportiert werden soll (hier z.B. Immobilien)

2. Im Feld "Exportname der 3DM-Datei:" sehen wir bereits den Namen "Stadthaus_Tutorial.3dm" eingetragen. Dies geschieht automatisch und richtet sich nach dem Namen den wir für unser Projekt vergeben haben. Es wäre uns an dieser Stelle allerdings möglich einen anderen Namen als Dateinamen zu vergeben.
(Anmerkung: Hier handelt es sich lediglich um den Dateinamen der .3dm-Datei, der später im jeweiligen Resourcen-Ordner der EEP-Version angezeigt wird)

Wir bestätigen unsere Einstellungen nun mit "OK" und sind nun bereit den Export des Modells zu starten. Hierzu wählen wir nun die Schaltfläche 9 ee export.jpg und erhalten das Export-Dialog-Fenster:



9 ee export-dialog.jpg



Die Einstellungen "Skalierung der globalen Textur" mit 100% bestätigen wir ebenso, wie die DXTx-Texturkompression. Bei "Typ des Modells" wählen wir Immobilien aus. Nun setzen wir bei "EEP Version" noch die EEP-Version, in die wir das Modell exportieren möchten. Die LOD Einstellungen - also Einstellungen zu Level Of Detail - benötigen wir bei einer derart einfacheren Immobilie nicht.

Somit haben wir alle Einstellungen für den Export gesetzt und betätigen nun die Schaltfläche "Modell exportieren" - und umgehend startet der HomeNos den Export des Modells in das .3dm-Format für EEP. War der Export nun erfolgreich erhalten wir abschließend folgende Informationen über den Export unseres Modells angezeigt:



9 ee export abschluss.jpg



Die exportierte .3dm-Datei mit der zugehörigen .ini-Datei liegt nun im Ordner HomeNostruktor8\Projects\Stadthaus_Tutorial\Release bereit und kann von dort wenn nötig in den gewünschten Immobilien-Ordner von EEP kopiert werden. Da wir in den "Einstellungen des Projekts" allerdings schon einen Kopierpfad angelegt haben, ist unser Stadthaus nun bereits für den Einsatz in EEP in der ausgewählten EEP-Version verfügbar.

Wir hoffen an dieser Stelle nun, dass Sie Spaß mit dem Tutorial hatten und wünschen Ihnen "Gutes Gelingen" bei Ihren weiteren, eigenen Modellvorhaben!



9 bild stadthaus.jpg









Zurück zur Startseite